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CAUTION: This information is subject to change without prior notice.

Copyright 2010, Opticon Sensors Europe BV, all rights reserved.

This manual may not, in whole or in part, be copied, photocopied, reproduced, translated or converted
to any electronic or machine readable form without prior written consent of Opticon Sensors Europe.

THE GENERAL USE AND FUNCTIONING OF THE BAR CODE SCANNER IS DESCRIBED IN THIS
DOCUMENT. ALSO GENERAL SETUP INSTRUCTIONS TO GET STARTED ARE DESCRIBED IN
THIS DOCUMENT. FOR FURTHER INSTRUCTIONS CONSULT OPTICON OR YOUR LOCAL
DEALER.

OPN2002 & OPN2003 BATCH DEMO MANUAL
(Version RFG35412)

The batch demo application for the OPN2002/3 demonstrates its capabilities to
store barcode data in a file and transmit this file to a remote host. The files are
transferred using the NetO protocol by using USB and/or the CRD2000 multi
cradle.

Since the OPN2002/3 terminals don't have a display to show any instructions
this demo application implements a user interface that consists entirely of using
just the 2 keys to scan barcodes. This brief setup guide describes all features as
well as handling instructions.

More product details, additional support and more configuration options to
customize this application to your own preferences (by using the Universal menu
book) will be updated at www.opticon.com

Capabilities of the Batch demo application

The following features are currently supported:

� Scans and stores barcodes into a database file on the internal RAM disk.

� Transmits the barcode data file to a remote PC or laptop using the NetO
protocol by either USB or the CRD2000 multi cradle.

� OSE Universal menu book support to configure all barcode decoders, pre-
and suffixes, read modes and various other options.

� Storing of configurations in non-volatile memory to allow all settings to be
restored after a reset.

� Configurable output format of the database file

� Easy software upgrading by USB (VCP) or the CRD-2000 multi cradle
(RS232) using Appload.
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System Requirements

Minimum required OS version

This demo application requires the following minimal OS version: RBGV0207.
To check the currently installed OS it's possible to use Appload (Utilities > Show
software version) to find the currently installed OS version.
To check the currently installed application version it is also possible to transmit
both the OS and application version by USB-VCP by reading the 'Z1' menu label.
(See Universal menu book chapter 7).

Minimum required NetO32 host application

This demo application uses Opticons NetO32 application to be able to transfer
files from the OPN2002 or OPN2003 to a remote PC or laptop. This application
can be downloaded from our web site. The minimum required NetO32 version is
Version 2.07.

Appload

To be able to install this application onto your OPN2002 you'll need to have
Appload installed on your PC. Make sure you have the latest version of Appload,
which can be found on our web site.

Please read the 'Loading of software' section of this manual before downloading
any software on the OPN2002/3.

Software updates

In the future more features and bug fixes are likely to be implemented into the
OS and this application. To find out if there are software updates available,
please check our web site.

All available software and documentation for the OPN2002/3 can be found at

www.opticon.com in the following section:

Service and support' > 'Software' / 'Manuals' > 'OPN2002/3
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Customizing your OPN2002 and OPN2003

OSE Universal Menu Book support

After loading this software on the OPN2002/3 for the first time, the application
will automatically be reset to default. If needed, reading the following default
label will also reset the application*

(The label below can be read without reading any SET/END labels)

OSE Handheld terminal
default (RS232 / USB)

In contrary to other Opticon hand held terminals, the OPN2002/3 also supports
the reading of various configuration options that can be found in our Universal
menu book**. This makes it possible to customize your application without
having to actually change the source code of this demo software.

The OPN2002/3 supports (most of the) menu options listed in the following
chapters:

� 1. Defaults (See the supported default label listed above)
� 3.1 Enabling/disabling readable codes
� 3.2 Setting of fixed, minimum and maximum lengths of readable codes
� 3.3 Code specific options (most options are supported except 2D symbology

options)
� 4.1 Case conversion
� 4.2 Set prefixes
� 4.3 Set suffixes
� 5.1 Read modes, add-on wait modes
� 5.1.1 Multiple read reset time
� 5.1.2 Quite zone options (margins)
� 5.2 Read time options
� 5.4 Redundancy
� 5.5 Positive and negative barcodes
� 6.1 Buzzer settings
� 6.2 Good read LED options
� 7.1 Diagnostics

* This demo application does not implement any of the OPN2002s Bluetooth
capabilities. A Bluetooth demo (RFG35312) for the OPN2002 is available on our
web site that demonstrates its Bluetooth capabilities.

** The Universal Menu Book can be downloaded from our web site.
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Barcode database file

All scanned unique barcodes are stored in a sorted database file with fixed
length records. Besides the barcode data also the quantity, serial number of the
OPN2002/3 and a date/time stamp can be stored.

The default format of each record in the database file is:

<Barcode (40 chars)>,<Quantity (6 chars)>,<hh:mm:ss>,<dd/mm/yyyy>

Example:

8710841030181                           ,    12,003278,14:41:03,23/11/2009
8710841090246                           ,     2,003278,14:41:04,23/11/2009
9780131103627                           ,     1,003278,14:41:00,23/11/2009

The OPN2002 automatically sorts the data base file after adding a scanned
barcode to the database. This is done to keep the database search functions
equally fast when the database is filled with many barcodes.*

The file name of the database is 'DATA.TXT', which is stored on the host PC or
laptop after the file has been transferred using the NetO protocol. By default the
NetO32 host application appends the transmitted databases, so all data of
multiple OPN2002s will end up in a single database file.

The resulting database file can be imported in various applications as, so called
comma-separated file.

To customize the output format of the database file, please check Appendix A.

*Note: If no quantity field is specified in the output format, then the database
won't be sorted and each bar code will be stored in a separate record.

Scanning barcodes

This demo uses the trigger button to enable the laser to scan barcodes.

If a barcode is read using the trigger key and good read beep is produced and a
green goodread LED is shown. The barcode is then stored in the database with a
quantity of '1'. If the same barcode is scanned again the quantity is incremented
by one.

To decrement the quantity of a barcode that's already in the database the small
delete key should be used to read the same barcode. A short good read beep is
produced and an orange red good read LED is shown.

If a barcode is scanned using the delete key that isn't present in the database or
that already has a quantity of '0' a low error beep is sound and a red led is
shown.

Negative quantities are by default not supported, but when using the 'Negative
quantities' option (see Appendix A) it is possible to scan negative quantities of
barcodes. When a specific barcode has a negative quantity the led color changes
to from green (add) or orange (subtract) to red on a good read and the sound
becomes slightly lower.
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Deleting the database file from the internal RAM disk

It might be possible that your OPN2002/3 has a full or corrupt RAM disk or
contains unwanted barcode data that you want to delete from the OPN2002/3.
In this situation it is possible to read the label below to erase all files from the
RAM disk.*

_+-FORMAT-+_

* Note: If the battery of the OPN2002/3 goes dry, then the OPN2002/3 won't
immediately loose it's barcode data. However, after a few days after becoming
empty all data on the RAM disk will be lost. Also the internal clock will reset if the
battery is completely drained. This requires the correct time to be reconfigured
using Appload.

Installing the USB driver

To be able to communicate with the OPN200x terminals using USB, you will need
to have its USB driver installed on your PC. This driver can be found on our web
site on the 'Service and Support' page.

www.opticon.com/SERVICE-AND-SUPPORT.aspx

The driver can be found in the section called 'Software' and then selecting the
OPN200x on the following page.

Two drivers can be downloaded for the OPN200x:

optousb32.exe USB driver for Windows 2000 , Windows XP (32bit) & Windows Vista/7 (32bit)

optousb64.exe USB driver for Windows XP (64bit) & Windows Vista/7 (64bit)

After installing the USB driver, you can connect your OPN2002 or OPN2003 to
USB using the mini-USB cable. Windows will then automatically install a virtual
COM port on your PC, which can be selected in various applications, like
Appload, Hyperterminal and Neto32.
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Configuring the CRD2000 cradle (OPN2002 only)

There are no configuration switches on the CRD2000, so the cradle itself won't
have to be configured. The CRD200 cradle works either via USB or via RS232
and both interfaces do not require any configuration.

The USB driver for this cradle can be downloaded from the Opticon web site in
the 'Service and support > software > CRD2000' section.

Configuring the host PC or laptop with NetO32

The OPN2002/3 can transmit its barcode database file to a remote PC or laptop
using the NetO-protocol. The data is transmitted by either a mini-USB cable or
by the CRD2000 multi cradle (OPN2002 only). To be able to receive the files on
the host, you'll need NetO32 to be installed. The latest version of NetO32 can
be downloaded from our web site under 'Service and support' > 'Software' >
'OPN2002/3'. Also more information about additional Neto32 features that aren't
described in this manual can be found the help file of NetO32.

Screenshot of the main window of NetO32
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CRD2000

When using the CRD2000 multi cradle certain configurations have to be made to
be able to correctly synchronize multiple OPN2002s that all want to transfer a
file to the host at the same time.

First of all, the RS232 settings have to be correctly configured, so besides
selecting the correct COM-port of the CRD2000, you will also have to select the
correct baud rate and other RS232 settings. The correct settings are shown in
the screenshot below.

RS232 settings in NetO32 when using the CRD2000 cradle

When using the NetO-protocol with a multi-cradle the use of terminal IDs is
mandatory to make sure that all files will be transferred without collisions and
errors.

Since the OPN2002 doesn't have a system menu in which a terminal ID can be
configured, each OPN2002 has its own unique serial number stored in non-
volatile memory. This demo application uses this unique serial number as
terminal ID. The serial number of OPN2002s is printed on the back of the
terminal, which makes it easy to add the serials numbers in NetO32.
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The 6-digit serial numbers of all your OPN2002s will have to added at 'Tools >
Options > Polling and Timing > Terminals to Poll'.

Screenshot of Polling and Timing settings with a list of OPN2002 serial numbers

When using the CRD200, don't configure a Poll Speed faster than 0,5s because
once an OPN2002 is communicating to the host, the other OPN2002s will be
temporarily muted for 250ms by the CRD2000 to avoid data collisions. For this
reason an OPN2002 responds to a poll after a random time ranging between
280ms and 480ms.

Mini USB cable

When using the mini-USB cable to retrieve your data from the OPN2002/3, the
RS232 configuration of NetO32 is limited to selecting the correct COM-port of
your OPN2002/3 in the RS232 configuration window of NetO32.

However, when using the mini-USB cable it's not possible to keep NetO32
running in the background due to the fact that the USB COM-port won't be
present on your system until you've physically connected your OPN2002/3 to
your USB port. Also it's not recommended to disconnect or to reconnect your
OPN2002/3 without having stopped the NetO-protocol first.

For these reasons it's easiest to place a NetO32 configuration file on your
desktop that downloads the data from the OPN2002 once and then immediately
closes again. This can be done by selecting the following 3 options in NetO32.

� Protocol > Polling and Timing > Protocol type: Single

� Protocol > Polling and Timing > Protocol type: Quit after single run

� Miscellaneous > Appearance > Run protocol on start

The correct sequence to retrieve the data from the OPN2002/3 using the mini
USB cable would then be connecting your OPN2002/3 to the USB port, clicking
on the NetO32 configuration file and then remove the OPN2002/3 from your PC
when desired. (Don't forget it regularly needs be charged as well.)
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Loading software on the OPN2002 and OPN2003

Software codes

All OPN2002 and OPN2003 terminals run an OS (operating system) and an
application. Both the OS and the application can be loaded by a small PC
application called Appload, which can be download from our web site.

The OPN200x terminals use an Operating System version that contains an
unique 3 letter code. Before you try to load a new Operating System on an
OPN200x terminal you have to know which Operating System file (i.e.
RBFVxxxx.S2) must be loaded on your terminal.

In the table below you can find the software codes for the OPN200x terminals.

Terminal OS Application
OPN2002 RBG RFG*
OPN2003 RBF RFF*

* It is often possible to load OPN2002 applications on the OPN2003 and vice
versa, because the hardware is mostly the same (besides Bluetooth capabilities
and cradle contacts that are only present on the OPN2002).

USB Driver

To be able to communicate with the OPN200x terminals using USB, you will need
to have its USB driver installed on your PC. This driver can be found on our web
site on the 'Service and Support' page.

www.opticon.com/SERVICE-AND-SUPPORT.aspx

The driver can be found in the section called 'Software' and then selecting the
OPN2002 or OPN2003.

Two drivers can be downloaded for the OPN200x:

optousb32.exe
USB driver for Windows 2000, Windows XP (32bit),
Windows Vista (32bit), Windows 7 (32 bit)

optousb64.exe
USB driver for Windows XP (64bit), Windows Vista (64bit),
Windows 7 (64 bit)

After installing the USB driver, you can connect your OPN2002 or OPN2003 to an
USB port using a mini-USB cable. Windows will then automatically install a
virtual COM port on your PC, which can be selected in various applications, like
Appload, Hyperterminal and Neto32.
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Loading software on the OPN2002

To load a new OS or application onto the OPN2002, you'll need a mini-USB cable
(which is supplied with the OPN2002) or the CRD2000 cradle.

To load an OS or application file, please follow the instructions below.

USB Cable � Connect the terminal to your PC or laptop using the mini-USB cable
� Start Appload and select the (Virtual) COM port of your OPN2002 in

Appload.
� Select the OS or application file in Appload using File > Download

Multi Cradle Because not all OS versions support the loading of software on multiple
OPN2002s at the same time, it is recommended to load the software with
only one OPN2002 in the cradle. To do this, follow the instructions below.

� Place one OPN2002 in the cradle.
� Start Appload and select the COM port of the CRD2000 cradle.
� Select the OS or application file in Appload using File > Download.
� Wait until the downloading has finished before inserting another

OPN2002 in the cradle.

IMPORTANT (!):
If you have OS version RBGV0207 or higher already installed on your
OPN2002s AND have Appload version 1.39 or higher, then it's also
possible to load software with multiple OPN2002s placed in the CRD2000
cradle.
If you try to load multiple OPN2002s simultaneously with an older version
of either Appload or the OS, then the end result would be OPN2002s with
faulty software that will need to be restored by loading the software again
(one at a time). See the 'trouble shooting' section for more information
about loading software on OPN2002s with faulty or crashing software.

� Read the important note above!
� Place up to 10 OPN2002s in the cradle.
� Start Appload and select the COM port of the CRD2000 cradle.
� Select the OS or application file in Appload using File > Download.
� To be sure that all OPN2002s have been updated, wait till Appload has

finished downloading the software on all OPN2002s.

Note: The OPN2002 that is currently being updated will be recognizable by
its orange LED, so never remove this OPN2002 from the cradle during the
downloading of the software.

Bluetooth <Currently not supported>

Loading software on the OPN2003

To load a new OS or application onto the OPN2003, you'll need a mini-USB.
Please follow the instructions below.

USB Cable � Connect the terminal to your PC or laptop using the mini-USB cable
� Start Appload and select the (Virtual) COM port of your OPN2002 in

Appload.
� Select the OS or application file in Appload using File > Download
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Trouble shooting

Since the OPN200x doesn't have a display, it also doesn't have a system menu
to resort to when you've installed a crashing application that prevents you from
loading new software on the OPN200x.

For this reason the OPN200x has a few escape mechanisms to allow you to
restart, halt your application and/or install new software. This can be very useful
in case the OPN200x has crashed or is constantly restarting due to a crashing
application.

Restart mechanisms

Automatic

The OPN200x has a watchdog timer to determine whether the OS is
still running or has crashed. This watchdog will cause the OPN200x
to restart after 3 seconds if the OS has crashed. This watchdog timer
will not cause a restart when only the application has crashed.

Manually

The OPN200x has a manual restart mechanism that allows you to
restart in situations that the OS is still running, but your the
application has crashed. In order to activate this mechanism, press
and hold the trigger or delete key for at least 20 seconds. After the
OPN200x has sounded the restart beep, you can release the key to
complete the restart.

Halting your application

� Firstly, make sure your battery isn't empty and your mini-USB cable is not
connected to the OPN200x.

� Then restart your application using one of the two restart methods listed
above, while keeping the trigger key pressed.

� While keeping the trigger key pressed, insert the mini-USB cable into the
OPN200x to halt the application.

If successful, the LED of your OPN200x should now be blinking orange. You
should now be able to load new application or OS software.

Halting the Operating System (only necessary in case a corrupt OS is
installed)

� Firstly, make sure your battery isn't empty and your mini-USB cable is not
connected to the OPN200x.

� Then restart your application using one of the 2 methods listed above, while
keeping the delete key pressed.

� While keeping the delete key pressed, insert the mini-USB cable into the
OPN200x to halt the Operating system.

If successful, the LED of your OPN200x should now be blinking red. You should
now be able to load a new OS.
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Appendix A: Database output formatting

The default output format of each record in the database file is:

<Barcode (40 chars)>,<Quantity (6 chars)>,<hh:mm:ss>,<dd/mm/yyyy>

However, this application allows you to customize this format to make it suitable
for your own application.

The following aspects of the output format are configurable. Read the
configuration barcodes on the following page to select the various options.

Date format 16 date formats are supported (see following page)

Time format 2 time formats are supported (hh:mm:ss and hh:mm)

Field separator
The field separator is the character that is used to
separate the various fields of a database record.
7 different separators can be selected.

Enable/disable
delete key

By default the small delete key can be used to remove a
previously read barcode from the database or reduce its
quantity by 1. By disabling the delete key this option
can be disabled.

Barcode field size

By default the barcode field size is 40 characters long,
but this can be changed between 1 and 99 characters by
reading 2 configuration labels on the following page to
specify both digits of the desired size.

Quantity field size
By default the quantity field is 6 characters long, but
this can be changed from 1 to 8 characters if desired.

Delete record
if quantity=0

By default a record is deleted if a barcode in the
database (with a quantity of 1) is read using the delete
key. However if you desire to keep a record of all delete
actions it is possible to leave the record with a quantity
of '0' in the database by disabling this option.

Negative quantities
allowed/not allowed

By default you can not delete a barcode that's not
present in the database. However for some purposes it
can be useful to be able to read them anyway to specify
a negative quantity.

Field output
sequence

Each record can contain up to 5 fields (barcode, date,
time, quantity and serial number). The output sequence
can be customized by reading up to 5 labels on the
following page.
By not specifying a quantity field each barcode will be
stored separately in the database. The database also
will not be sorted and in case a barcode is read using
the delete key the last occurrence in the database will
be deleted.
It is not allowed to not specify a barcode field in the
output sequence.

Note: When changing the field sequence, make sure
you've downloaded the existing database file from the
OPN200x or otherwise formatted the RAM disk.
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Version history

RFG35410 First release December 7th, 2009

RFG35411 Added configurable database formatting December 14th, 2009

RFG35412 Fixed very slow storing of barcodes February 3rd, 2010

Please check our web site at www.opticon.com to see if there are updates
available for this application, the Operating System, NetO32 and/or this manual.


